summaryrefslogtreecommitdiff
path: root/linux.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-04-08 22:28:13 -0700
committerBen Sima <ben@bsima.me>2019-04-08 22:28:13 -0700
commitc59a5a301a3b9074b0d6d7ba5c0bef145b8a95d9 (patch)
tree6e39321070bd709f9b4570188799af08ede775b1 /linux.nix
parent52a864bd52d522bfcdc9bed4625fa04b39c935d2 (diff)
load xtheme state from ~/.local/share/xtheme
Diffstat (limited to 'linux.nix')
-rw-r--r--linux.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/linux.nix b/linux.nix
index 6bf72ab..1000c4f 100644
--- a/linux.nix
+++ b/linux.nix
@@ -1,10 +1,10 @@
-{ pkgs, ... }:
+{ pkgs, lib, ... }:
let
solarized-xresources = ./xresources;
- themeVar = builtins.getEnv "XTHEME";
- defaultTheme = "light";
- theme = if themeVar == "" then defaultTheme else themeVar;
+ homedir = builtins.getEnv "HOME";
+ theme = lib.removeSuffix "\n"
+ (builtins.readFile "${homedir}/.local/share/xtheme");
colors = {
"dark" = {
background = "#292b2e";