summaryrefslogtreecommitdiff
path: root/linux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'linux.nix')
-rw-r--r--linux.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/linux.nix b/linux.nix
index 6bf72ab..1000c4f 100644
--- a/linux.nix
+++ b/linux.nix
@@ -1,10 +1,10 @@
-{ pkgs, ... }:
+{ pkgs, lib, ... }:
let
solarized-xresources = ./xresources;
- themeVar = builtins.getEnv "XTHEME";
- defaultTheme = "light";
- theme = if themeVar == "" then defaultTheme else themeVar;
+ homedir = builtins.getEnv "HOME";
+ theme = lib.removeSuffix "\n"
+ (builtins.readFile "${homedir}/.local/share/xtheme");
colors = {
"dark" = {
background = "#292b2e";