summaryrefslogtreecommitdiff
path: root/vim.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2018-05-21 16:47:04 -0700
committerBen Sima <ben@bsima.me>2018-05-21 16:47:04 -0700
commitd74239814b2095d4e85b435a4942845e7e60f40d (patch)
tree82bca2ed91860798042b776842a9b2c8fa691fea /vim.nix
parent10af53f0094ccc74d818dc2fff101363e3da0995 (diff)
Fix spacing
Diffstat (limited to 'vim.nix')
-rw-r--r--vim.nix48
1 files changed, 24 insertions, 24 deletions
diff --git a/vim.nix b/vim.nix
index dbb1a9c..aeabaef 100644
--- a/vim.nix
+++ b/vim.nix
@@ -2,7 +2,7 @@
enable = true;
plugins = [
"colors-solarized"
- "fugitive"
+ "fugitive"
];
settings = {
ignorecase = true;
@@ -17,27 +17,27 @@
set background=light
else
set background=dark
- endif
- colorscheme solarized
- filetype plugin indent on
- set cuc cul " Crosshair
- set cc=80 " 80 column lines
- set linebreak " Break lines at word (requires Wrap lines)
- set showbreak= " Wrap-broken line prefix
- set textwidth=80 " Line wrap (number of cols)
- set showmatch " Highlight matching brace
- set visualbell " Use visual bell (no beeping)
- set hlsearch " Highlight all search results
- set smartcase " Enable smart-case search
- set incsearch " Searches for strings incrementally
- ret autoindent " Auto-indent new lines
- set shiftwidth=4 " Number of auto-indent spaces
- set smartindent " Enable smart-indent
- set smarttab " Enable smart-tabs
- set ruler " Show row and column ruler information
- set backspace=indent,eol,start " Backspace behaviour
- imap fd <Esc>
- set wildmenu " cool menu effect
- set mouse=a
- '';
+ endif
+ colorscheme solarized
+ filetype plugin indent on
+ set cuc cul " Crosshair
+ set cc=80 " 80 column lines
+ set linebreak " Break lines at word (requires Wrap lines)
+ set showbreak= " Wrap-broken line prefix
+ set textwidth=80 " Line wrap (number of cols)
+ set showmatch " Highlight matching brace
+ set visualbell " Use visual bell (no beeping)
+ set hlsearch " Highlight all search results
+ set smartcase " Enable smart-case search
+ set incsearch " Searches for strings incrementally
+ ret autoindent " Auto-indent new lines
+ set shiftwidth=4 " Number of auto-indent spaces
+ set smartindent " Enable smart-indent
+ set smarttab " Enable smart-tabs
+ set ruler " Show row and column ruler information
+ set backspace=indent,eol,start " Backspace behaviour
+ imap fd <Esc>
+ set wildmenu " cool menu effect
+ set mouse=a
+ '';
}