summaryrefslogtreecommitdiff
path: root/reify-health/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'reify-health/shell.nix')
-rw-r--r--reify-health/shell.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/reify-health/shell.nix b/reify-health/shell.nix
new file mode 100644
index 0000000..7331059
--- /dev/null
+++ b/reify-health/shell.nix
@@ -0,0 +1,18 @@
+with import <nixpkgs> {};
+
+{
+ dm-datastream = pkgs.stdenv.mkDerivation rec {
+ name = "ReifyHealth-interview";
+ src = ./.;
+
+ buildInputs = [
+ leiningen
+ openjdk
+ ];
+
+ # lein complains without this:
+ shellHook = ''
+ unset CLASSPATH;
+ '';
+ };
+}