summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2022-08-01 10:12:27 -0400
committerBen Sima <ben@bsima.me>2022-08-01 10:12:27 -0400
commit6797db61eba38f328b95854ef5f0e8befea407dc (patch)
tree8c5c14cf43d9b154a9189157a87b1ad9f7145a28 /Biz/Bild.nix
parentd8fe6f7ac54f155fe5a3c33509249a70d0c816c5 (diff)
Add missing runtime dependencies to bild
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index 40309a1..abff330 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -48,7 +48,9 @@ rec {
propagatedBuildInputs = with nixpkgs; [
pkg-config
guile_3_0
- sbcl
+ rustc
+ gcc
+ (private.sbclWith (p: with p; [asdf alexandria])) # just enough to build Example.lisp
];
strictDeps = true;
buildPhase = ''
@@ -126,7 +128,6 @@ rec {
name = "bizdev";
# this should just be dev tools
buildInputs = with nixpkgs.pkgs; linters ++ [
- gcc
bild
ctags
figlet