summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-08-17 21:21:07 -0400
committerBen Sima <ben@bsima.me>2023-08-17 22:44:04 -0400
commitaac50fb4a0eea25a057bb2d7ebe80961c542a2a5 (patch)
treeb6e6a26cd7dec9937003aa33ec6f0875be2ee99d /Biz/Bild.nix
parentcc6aac612e36da3c9b9b4e47fc16ed512a79f2d9 (diff)
Nixify C build
This is working with libsodium as an example. Its unfortunate that we need the extra ':arg -lsodium' but how else can I get the name of the library for linking? Is that something in the nix attr metadata? Anyway, an optimization for another day.
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index 94305bc..ee0b1fe 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -30,6 +30,8 @@ rec {
pythonPackages = nixpkgs.python3Packages;
pythonWith = nixpkgs.python3.withPackages;
+ cPackages = nixpkgs.pkgs;
+
ghcPackageSetFull = private.ghcWith private.haskellDeps;
ghcPackageSetBild = private.ghcWith (hpkgs: with hpkgs; [
aeson async base bytestring conduit conduit-extra containers directory
@@ -53,8 +55,6 @@ rec {
(private.ghcWith (hpkgs: with hpkgs; []))
/* disable until nixified builds are complete */
- # c deps
- gcc gdb valgrind argp-standalone SDL
# lisp deps
guile
(private.sbclWith (p: with p; [asdf alexandria])) # just enough to build Example.lisp