summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/outlines.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Biz/Bild/Deps/outlines.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Biz/Bild/Deps/outlines.nix')
-rw-r--r--Biz/Bild/Deps/outlines.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/Biz/Bild/Deps/outlines.nix b/Biz/Bild/Deps/outlines.nix
deleted file mode 100644
index 29ef41b..0000000
--- a/Biz/Bild/Deps/outlines.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-{ lib, sources, buildPythonPackage, interegular, jinja2, lark, numpy, perscache
-, pillow, pydantic, regex, scipy, tenacity, torch }:
-
-buildPythonPackage rec {
- pname = "outlines";
- version = sources.outlines.rev;
- format = "pyproject";
-
- src = sources.outlines;
-
- propagatedBuildInputs = [
- interegular
- jinja2
- lark
- numpy
- perscache
- pillow
- pydantic
- regex
- scipy
- tenacity
- torch
- ];
-
- doCheck = false; # no tests currently
- pythonImportsCheck = [ "outlines" ];
-
- meta = with lib; {
- description = "Probabilistic Generative Model Programming";
- homepage = "https://github.com/normal-computing/outlines";
- license = licenses.asl20;
- maintainers = with maintainers; [ bsima ];
- };
-}