summaryrefslogtreecommitdiff
path: root/Biz/Bild/Deps/outlines.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Bild/Deps/outlines.nix')
-rw-r--r--Biz/Bild/Deps/outlines.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/Biz/Bild/Deps/outlines.nix b/Biz/Bild/Deps/outlines.nix
deleted file mode 100644
index 29ef41b..0000000
--- a/Biz/Bild/Deps/outlines.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-{ lib, sources, buildPythonPackage, interegular, jinja2, lark, numpy, perscache
-, pillow, pydantic, regex, scipy, tenacity, torch }:
-
-buildPythonPackage rec {
- pname = "outlines";
- version = sources.outlines.rev;
- format = "pyproject";
-
- src = sources.outlines;
-
- propagatedBuildInputs = [
- interegular
- jinja2
- lark
- numpy
- perscache
- pillow
- pydantic
- regex
- scipy
- tenacity
- torch
- ];
-
- doCheck = false; # no tests currently
- pythonImportsCheck = [ "outlines" ];
-
- meta = with lib; {
- description = "Probabilistic Generative Model Programming";
- homepage = "https://github.com/normal-computing/outlines";
- license = licenses.asl20;
- maintainers = with maintainers; [ bsima ];
- };
-}