summaryrefslogtreecommitdiff
path: root/Biz/Bild/Sources.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-08-16 14:18:10 -0400
committerBen Sima <ben@bsima.me>2023-08-16 18:25:00 -0400
commit7d7e0c02351303489d5555627337a39b519b536a (patch)
tree794817b6d6046a265a129c910885339058773198 /Biz/Bild/Sources.nix
parent30d03210f7ac5b12235760f625bac5ff3aa3f85a (diff)
Get python targets building
I added 'black' to Biz/Lint.hs, but not the others because they rely on dependencies being in the PYTHONPATH to work, so they are only relevant in nix builds and repls. I also made some other tweaks to the python checkPhase and linted all the files. Everything should be building and linting correctly now.
Diffstat (limited to 'Biz/Bild/Sources.nix')
-rw-r--r--Biz/Bild/Sources.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/Biz/Bild/Sources.nix b/Biz/Bild/Sources.nix
index 1938409..927683a 100644
--- a/Biz/Bild/Sources.nix
+++ b/Biz/Bild/Sources.nix
@@ -126,6 +126,7 @@ let
optionalAttrs = cond: as: if cond then as else {};
# fetchTarball version that is compatible between all the versions of Nix
+ # deadnix: skip
builtins_fetchTarball = { url, name ? null, sha256 }@attrs:
let
inherit (builtins) lessThan nixVersion fetchTarball;
@@ -136,6 +137,7 @@ let
fetchTarball attrs;
# fetchurl version that is compatible between all the versions of Nix
+ # deadnix: skip
builtins_fetchurl = { url, name ? null, sha256 }@attrs:
let
inherit (builtins) lessThan nixVersion fetchurl;