summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Git.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-11-16 11:47:36 -0500
committerBen Sima <ben@bsima.me>2020-11-16 11:47:36 -0500
commit656816ed9af6277bbeb1c5e74471bace3a78e5be (patch)
tree8d9b28d4a804fdb258f17b32e675bf9a4dcf8a98 /Biz/Cloud/Git.nix
parenteb3ee6f1867eb19d2a262826038b2615b3def762 (diff)
get build working and capitalize more files
Diffstat (limited to 'Biz/Cloud/Git.nix')
-rw-r--r--Biz/Cloud/Git.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/Biz/Cloud/Git.nix b/Biz/Cloud/Git.nix
new file mode 100644
index 0000000..6104ced
--- /dev/null
+++ b/Biz/Cloud/Git.nix
@@ -0,0 +1,17 @@
+{ pkgs, ... }:
+
+{
+ services = {
+ gitolite = {
+ enable = true;
+ enableGitAnnex = true;
+ dataDir = "/srv/git";
+ user = "git";
+ group = "git";
+ extraGitoliteRc = ''
+ $RC{SITE_INFO} = 'a computer is a bicycle for the mind.';
+ '';
+ adminPubkey = builtins.readFile ../Keys/Ben.pub;
+ };
+ };
+}