summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Cloud/Git.nix')
-rw-r--r--Biz/Cloud/Git.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/Biz/Cloud/Git.nix b/Biz/Cloud/Git.nix
new file mode 100644
index 0000000..6104ced
--- /dev/null
+++ b/Biz/Cloud/Git.nix
@@ -0,0 +1,17 @@
+{ pkgs, ... }:
+
+{
+ services = {
+ gitolite = {
+ enable = true;
+ enableGitAnnex = true;
+ dataDir = "/srv/git";
+ user = "git";
+ group = "git";
+ extraGitoliteRc = ''
+ $RC{SITE_INFO} = 'a computer is a bicycle for the mind.';
+ '';
+ adminPubkey = builtins.readFile ../Keys/Ben.pub;
+ };
+ };
+}