summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Git.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-12-21 10:40:06 -0400
committerBen Sima <ben@bsima.me>2024-12-21 09:40:06 -0500
commit79390d4eea20ca15fd8e088345528f31ed5fad1e (patch)
treef08b71ffddead23484fd6df9e1aff54d20f12768 /Biz/Cloud/Git.nix
parent18956baad9cde85bc55bd0113092e51786d9e1ee (diff)
Upgrade to nixos-24.05
I think this is the only "supported" nixos version now. But in any case scipy seemed to be broken on the older version, and I couldn't build my code that uses llm. Also, this allows me to get rid of the bild.os-unstable thing for Beryllium, which was just a sitting timebomb of breaking stuff. There are a lot of changes here because ruff updated to the very latest, and it changed some minor lint things. Also with the new nixos I get a proper cgit module, and some other breaking changes needed fixing.
Diffstat (limited to 'Biz/Cloud/Git.nix')
-rw-r--r--Biz/Cloud/Git.nix42
1 files changed, 19 insertions, 23 deletions
diff --git a/Biz/Cloud/Git.nix b/Biz/Cloud/Git.nix
index 3ef4530..bc97d23 100644
--- a/Biz/Cloud/Git.nix
+++ b/Biz/Cloud/Git.nix
@@ -6,6 +6,25 @@ let
ports = import ./Ports.nix;
in {
services = {
+ cgit.cloud = {
+ enable = true;
+ nginx.location = "/git";
+ nginx.virtualHost = "/git";
+ scanPath = "/var/git/repositories";
+ settings = {
+ strict-export = "git-daemon-export-ok";
+ css = "/git/cgit.css";
+ logo = "/git/cgit.png";
+ root-title = "ben's git repos";
+ root-desc = "building";
+ enable-git-config = 1;
+ clone-url = lib.strings.concatStringsSep " " [
+ "https://$HTTP_HOST/git/$CGIT_REPO_URL"
+ "git://$HTTP_HOST/$CGIT_REPO_URL"
+ "git@$HTTP_HOST:$CGIT_REPO_URL"
+ ];
+ };
+ };
gitolite = {
enable = true;
enableGitAnnex = true;
@@ -33,29 +52,6 @@ in {
user = "gitDaemon";
group = "gitDaemon";
};
- nginx.virtualHosts.${domain}.cgit = {
- enable = true;
- location = "/git";
- allowCrawlers = false;
- virtual-root = "/git";
- css = "/git/cgit.css";
- logo = "/git/cgit.png";
- root-title = "ben's git repos";
- root-desc = "building";
- enable-git-config = 1;
- clone-url = lib.strings.concatStringsSep " " [
- "https://$HTTP_HOST/git/$CGIT_REPO_URL"
- "git://$HTTP_HOST/$CGIT_REPO_URL"
- "git@$HTTP_HOST:$CGIT_REPO_URL"
- ];
- include = [
- # these depend on order, scan-path must come last
- (builtins.toFile "cgitrc" ''
- strict-export=git-daemon-export-ok
- scan-path=${root}/repositories
- '')
- ];
- };
gerrit = {
enable = false;
builtinPlugins = [