summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Cloud/Git.nix')
-rw-r--r--Biz/Cloud/Git.nix42
1 files changed, 19 insertions, 23 deletions
diff --git a/Biz/Cloud/Git.nix b/Biz/Cloud/Git.nix
index 3ef4530..bc97d23 100644
--- a/Biz/Cloud/Git.nix
+++ b/Biz/Cloud/Git.nix
@@ -6,6 +6,25 @@ let
ports = import ./Ports.nix;
in {
services = {
+ cgit.cloud = {
+ enable = true;
+ nginx.location = "/git";
+ nginx.virtualHost = "/git";
+ scanPath = "/var/git/repositories";
+ settings = {
+ strict-export = "git-daemon-export-ok";
+ css = "/git/cgit.css";
+ logo = "/git/cgit.png";
+ root-title = "ben's git repos";
+ root-desc = "building";
+ enable-git-config = 1;
+ clone-url = lib.strings.concatStringsSep " " [
+ "https://$HTTP_HOST/git/$CGIT_REPO_URL"
+ "git://$HTTP_HOST/$CGIT_REPO_URL"
+ "git@$HTTP_HOST:$CGIT_REPO_URL"
+ ];
+ };
+ };
gitolite = {
enable = true;
enableGitAnnex = true;
@@ -33,29 +52,6 @@ in {
user = "gitDaemon";
group = "gitDaemon";
};
- nginx.virtualHosts.${domain}.cgit = {
- enable = true;
- location = "/git";
- allowCrawlers = false;
- virtual-root = "/git";
- css = "/git/cgit.css";
- logo = "/git/cgit.png";
- root-title = "ben's git repos";
- root-desc = "building";
- enable-git-config = 1;
- clone-url = lib.strings.concatStringsSep " " [
- "https://$HTTP_HOST/git/$CGIT_REPO_URL"
- "git://$HTTP_HOST/$CGIT_REPO_URL"
- "git@$HTTP_HOST:$CGIT_REPO_URL"
- ];
- include = [
- # these depend on order, scan-path must come last
- (builtins.toFile "cgitrc" ''
- strict-export=git-daemon-export-ok
- scan-path=${root}/repositories
- '')
- ];
- };
gerrit = {
enable = false;
builtinPlugins = [