summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Hardware.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
committerBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
commitdb373a8c727cad91d375b40a6c70b11ed73bdafb (patch)
treea7ed24e98242b6e38f44cb0c9884718d248cc613 /Biz/Cloud/Hardware.nix
parent5c8ef1bf4dff4fc7c6e66a57673a81477bcc850a (diff)
Add nixfmt to Lint.hs
nixfmt is the soon-to-be official formatter for Nix code, as per the NixOS GitHub group. So I figure I should just adopt it without worrying too much about the specifics of the formatting. I just formatted everything in one go, hence the huge diff, oh well.
Diffstat (limited to 'Biz/Cloud/Hardware.nix')
-rw-r--r--Biz/Cloud/Hardware.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/Biz/Cloud/Hardware.nix b/Biz/Cloud/Hardware.nix
index ab775dc..8fdbd4e 100644
--- a/Biz/Cloud/Hardware.nix
+++ b/Biz/Cloud/Hardware.nix
@@ -1,7 +1,9 @@
-{ modulesPath, ... }:
-{
+{ modulesPath, ... }: {
imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
boot.loader.grub.device = "/dev/vda";
boot.initrd.kernelModules = [ "nvme" ];
- fileSystems."/" = { device = "/dev/vda1"; fsType = "ext4"; };
+ fileSystems."/" = {
+ device = "/dev/vda1";
+ fsType = "ext4";
+ };
}