summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-01-04 17:36:15 -0500
committerBen Sima <ben@bsima.me>2023-01-04 17:36:15 -0500
commit47cd029db307d281d66188c62238a91f69170fcd (patch)
tree75373d81732d27c5a58b9f0ab1ab8d2a55321997 /Biz/Cloud/Web.nix
parent52fd37e2ac382a2630d3fe3d22ef86908d67a6b6 (diff)
Deploy nostr relay service
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index 5f4789a..069062e 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -201,6 +201,20 @@ in
locations."/".proxyPass = "http://localhost:${toString ports.botamusique}";
};
+ "nostr.${rootDomain}" = {
+ forceSSL = true;
+ useACMEHost = rootDomain;
+ locations."/" = {
+ proxyPass = "http://localhost:${toString ports.nostr-relay}";
+ extraConfig = ''
+ proxy_http_version 1.1;
+ proxy_set_header Upgrade $http_upgrade;
+ proxy_set_header Connection "Upgrade";
+ proxy_set_header Host $host;
+ '';
+ };
+ };
+
"notebook.${rootDomain}" = {
forceSSL = true;
useACMEHost = rootDomain;
@@ -239,6 +253,7 @@ in
"sabten"
"cal"
"notebook"
+ "nostr"
"reddit"
"old.reddit"
"www.reddit"