summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-04-16 20:20:43 -0400
committerBen Sima <ben@bsima.me>2021-11-26 13:47:33 -0500
commitad59ca4ed13e3f329a8cba9e2d009f41c564af9f (patch)
tree0c2f719c9b304b5db199267bd892647a5c0e7aee /Biz/Cloud/Web.nix
parent20d6537e45b6380a70f2e9c0d0bd89bb69a4892f (diff)
Run gmnisrv in the cloud
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index 74fc27e..bc0d921 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -6,6 +6,21 @@ let
in
{
services = {
+ gmnisrv = {
+ enable = true;
+ settings = {
+ listen = "0.0.0.0:1965 [::]:1965";
+ ":tls" = { store = "/var/lib/gmnisrv"; };
+ "bsima.me" = {
+ "root" = "/www/ben/public";
+ };
+ "simatime.com" = {
+ "root" = "/www/simatime.com/public";
+ "cgi" = "on";
+ };
+ };
+ };
+
nginx = {
enable = true;
recommendedGzipSettings = true;