summaryrefslogtreecommitdiff
path: root/Biz/Cloud/Web.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Cloud/Web.nix')
-rw-r--r--Biz/Cloud/Web.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/Biz/Cloud/Web.nix b/Biz/Cloud/Web.nix
index 74fc27e..bc0d921 100644
--- a/Biz/Cloud/Web.nix
+++ b/Biz/Cloud/Web.nix
@@ -6,6 +6,21 @@ let
in
{
services = {
+ gmnisrv = {
+ enable = true;
+ settings = {
+ listen = "0.0.0.0:1965 [::]:1965";
+ ":tls" = { store = "/var/lib/gmnisrv"; };
+ "bsima.me" = {
+ "root" = "/www/ben/public";
+ };
+ "simatime.com" = {
+ "root" = "/www/simatime.com/public";
+ "cgi" = "on";
+ };
+ };
+ };
+
nginx = {
enable = true;
recommendedGzipSettings = true;