summaryrefslogtreecommitdiff
path: root/Biz/Dev/Hoogle.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
committerBen Sima <ben@bsima.me>2024-04-01 13:30:45 -0400
commitdb373a8c727cad91d375b40a6c70b11ed73bdafb (patch)
treea7ed24e98242b6e38f44cb0c9884718d248cc613 /Biz/Dev/Hoogle.nix
parent5c8ef1bf4dff4fc7c6e66a57673a81477bcc850a (diff)
Add nixfmt to Lint.hs
nixfmt is the soon-to-be official formatter for Nix code, as per the NixOS GitHub group. So I figure I should just adopt it without worrying too much about the specifics of the formatting. I just formatted everything in one go, hence the huge diff, oh well.
Diffstat (limited to 'Biz/Dev/Hoogle.nix')
-rw-r--r--Biz/Dev/Hoogle.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/Biz/Dev/Hoogle.nix b/Biz/Dev/Hoogle.nix
index 02330b5..213a31c 100644
--- a/Biz/Dev/Hoogle.nix
+++ b/Biz/Dev/Hoogle.nix
@@ -25,7 +25,7 @@ in {
};
packages = mkOption {
- default = _hp: [];
+ default = _hp: [ ];
defaultText = "hp: []";
example = "hp: with hp; [ text lens ]";
description = ''
@@ -64,7 +64,9 @@ in {
serviceConfig = {
Restart = "always";
- ExecStart = ''${hoogleEnv}/bin/hoogle server --local --port ${toString cfg.port} --home ${cfg.home} --host ${cfg.host}'';
+ ExecStart = "${hoogleEnv}/bin/hoogle server --local --port ${
+ toString cfg.port
+ } --home ${cfg.home} --host ${cfg.host}";
DynamicUser = true;