summaryrefslogtreecommitdiff
path: root/Biz/Dev/Lithium/Hardware.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-10-09 15:12:06 -0400
committerBen Sima <ben@bsima.me>2023-10-10 13:16:49 -0400
commit39481b42c19f91ee714987176937c089d2c170cb (patch)
treed526d0e850ed94310cd566e3ac6917753b90bc5d /Biz/Dev/Lithium/Hardware.nix
parent6baad9c5fae4a7b8ea07376a0be52443eaa488fa (diff)
Add beryllium and connect via VPN
I finally got everything setup for the new dev machine, but I ran into a networking problem: I can't tell my home router to expose the ssh port 22 to multiple hosts. I could have made beryllium use a different port, but instead I decided to use tailscale, and this seems to work well. I still don't have hostname routing working, but maybe that's a simple config in tailscale somewhere. Eventually I will get all intra-networking stuff to use a vpn, but for now just using it for beryllium is fine.
Diffstat (limited to 'Biz/Dev/Lithium/Hardware.nix')
-rw-r--r--Biz/Dev/Lithium/Hardware.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/Biz/Dev/Lithium/Hardware.nix b/Biz/Dev/Lithium/Hardware.nix
new file mode 100644
index 0000000..4d835aa
--- /dev/null
+++ b/Biz/Dev/Lithium/Hardware.nix
@@ -0,0 +1,36 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ lib, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [
+ "xhci_pci" "ahci" "usb_storage" "usbhid" "sd_mod"
+ ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [
+ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/f08dd8f9-787c-4e2a-a0cc-7019edc2ce2b";
+ fsType = "ext4";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/C67C-D7B5";
+ fsType = "vfat";
+ };
+
+ fileSystems."/mnt/campbell" = {
+ device = "/dev/disk/by-uuid/037df3ae-4609-402c-ab1d-4593190d0ee7";
+ fsType = "ext4";
+ };
+
+ swapDevices = [ ];
+
+ powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+}