summaryrefslogtreecommitdiff
path: root/Biz/Dev/Lithium/Hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Dev/Lithium/Hardware.nix')
-rw-r--r--Biz/Dev/Lithium/Hardware.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/Biz/Dev/Lithium/Hardware.nix b/Biz/Dev/Lithium/Hardware.nix
new file mode 100644
index 0000000..4d835aa
--- /dev/null
+++ b/Biz/Dev/Lithium/Hardware.nix
@@ -0,0 +1,36 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ lib, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [
+ "xhci_pci" "ahci" "usb_storage" "usbhid" "sd_mod"
+ ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [
+ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/f08dd8f9-787c-4e2a-a0cc-7019edc2ce2b";
+ fsType = "ext4";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/C67C-D7B5";
+ fsType = "vfat";
+ };
+
+ fileSystems."/mnt/campbell" = {
+ device = "/dev/disk/by-uuid/037df3ae-4609-402c-ab1d-4593190d0ee7";
+ fsType = "ext4";
+ };
+
+ swapDevices = [ ];
+
+ powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+}