summaryrefslogtreecommitdiff
path: root/Biz/Dev/Vpn.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-11-15 14:55:37 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:06:49 -0500
commit6513755670892983db88a6633b8c1ea6019c03d1 (patch)
tree44e9eccdb7a3a74ab7e96a8fee7572dd6a78dc73 /Biz/Dev/Vpn.nix
parentae7b7e0186b5f2e0dcd4d5fac0a71fa264caedc2 (diff)
Re-namespace some stuff to Omni
I was getting confused about what is a product and what is internal infrastructure; I think it is good to keep those things separate. So I moved a bunch of stuff to an Omni namespace, actually most stuff went there. Only things that are explicitly external products are still in the Biz namespace.
Diffstat (limited to 'Biz/Dev/Vpn.nix')
-rw-r--r--Biz/Dev/Vpn.nix33
1 files changed, 0 insertions, 33 deletions
diff --git a/Biz/Dev/Vpn.nix b/Biz/Dev/Vpn.nix
deleted file mode 100644
index 9b791b7..0000000
--- a/Biz/Dev/Vpn.nix
+++ /dev/null
@@ -1,33 +0,0 @@
-{ config, ... }:
-
-let
- ports = import ../Cloud/Ports.nix;
- domain = "headscale.simatime.com";
-in {
- services.headscale = {
- enable = true;
- address = "0.0.0.0";
- port = ports.headscale;
- settings = { dns.base_domain = "simatime.com"; };
- };
-
- services.nginx.virtualHosts.${domain} = {
- forceSSL = true;
- enableAcme = true;
- locations."/" = {
- proxyPass = "http://localhost:${toString ports.headscale}";
- proxyWebsockets = true;
- };
- };
-
- environment.systemPackages = [ config.services.headscale.package ];
-
- services.tailscale.enable = true;
-
- networking.firewall = {
- checkReversePath = "loose";
- trustedInterfaces = [ "tailscale0" ];
- allowedUDPPorts = [ config.services.tailscale.port ];
- };
-
-}