summaryrefslogtreecommitdiff
path: root/Biz/Dev/Vpn.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Dev/Vpn.nix')
-rw-r--r--Biz/Dev/Vpn.nix33
1 files changed, 0 insertions, 33 deletions
diff --git a/Biz/Dev/Vpn.nix b/Biz/Dev/Vpn.nix
deleted file mode 100644
index 9b791b7..0000000
--- a/Biz/Dev/Vpn.nix
+++ /dev/null
@@ -1,33 +0,0 @@
-{ config, ... }:
-
-let
- ports = import ../Cloud/Ports.nix;
- domain = "headscale.simatime.com";
-in {
- services.headscale = {
- enable = true;
- address = "0.0.0.0";
- port = ports.headscale;
- settings = { dns.base_domain = "simatime.com"; };
- };
-
- services.nginx.virtualHosts.${domain} = {
- forceSSL = true;
- enableAcme = true;
- locations."/" = {
- proxyPass = "http://localhost:${toString ports.headscale}";
- proxyWebsockets = true;
- };
- };
-
- environment.systemPackages = [ config.services.headscale.package ];
-
- services.tailscale.enable = true;
-
- networking.firewall = {
- checkReversePath = "loose";
- trustedInterfaces = [ "tailscale0" ];
- allowedUDPPorts = [ config.services.tailscale.port ];
- };
-
-}