summaryrefslogtreecommitdiff
path: root/Biz/Users.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-11-12 17:13:39 -0800
committerBen Sima <ben@bsima.me>2020-11-12 17:21:13 -0800
commit890e44ebcc11c48f7347aa60748a84c48261aa5e (patch)
tree894e30ce7a0c81ef3968c04f82d068a65c15b0f5 /Biz/Users.nix
parent19f5402bec9f6346463b83536cc22d7f4525bc18 (diff)
Get Biz.Dev setup again
Also correctly renamed the files (didn't work the first time thanks to the macOS filesystem) and moved the default build.os settings to a OsBase.nix file to be used via imports.
Diffstat (limited to 'Biz/Users.nix')
-rw-r--r--Biz/Users.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/Biz/Users.nix b/Biz/Users.nix
new file mode 100644
index 0000000..8a804ca
--- /dev/null
+++ b/Biz/Users.nix
@@ -0,0 +1,43 @@
+{ config, ... }:
+
+{
+ users.motd = ''
+
+ welcome to the simatime network!
+ your host is '${config.networking.hostName}'
+
+ '';
+ users.mutableUsers = false;
+ users.users = { #
+ # bots
+ #
+ deploy = {
+ isNormalUser = true;
+ home = "/home/deploy";
+ openssh.authorizedKeys.keyFiles = [ ./Keys/Deploy.pub ];
+ extraGroups = [ "wheel" ];
+ };
+ #
+ # humans
+ #
+ root.openssh.authorizedKeys.keyFiles = [ ./Keys/Ben.pub ];
+ root.password = "erewhon";
+
+ ben = {
+ description = "Ben Sima";
+ isNormalUser = true;
+ home = "/home/ben";
+ openssh.authorizedKeys.keyFiles = [ ./Keys/Ben.pub ];
+ extraGroups = [ "wheel" "docker" ];
+ hashedPassword =
+ "$6$SGhdoRB6DhWe$elW8RQE1ebe8JKf1ALW8jGZTPCyn2rpq/0J8MV/A9y8qFMEhA.Z2eiexMgptohZAK5kcGOc6HIUgNzJqnDUvY.";
+ };
+ nick = {
+ description = "Nick Sima";
+ isNormalUser = true;
+ home = "/home/nick";
+ openssh.authorizedKeys.keyFiles = [ ./Keys/Nick.pub ];
+ extraGroups = [ "docker" ];
+ };
+ };
+}