summaryrefslogtreecommitdiff
path: root/Biz/Users.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/Users.nix')
-rw-r--r--Biz/Users.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/Biz/Users.nix b/Biz/Users.nix
new file mode 100644
index 0000000..8a804ca
--- /dev/null
+++ b/Biz/Users.nix
@@ -0,0 +1,43 @@
+{ config, ... }:
+
+{
+ users.motd = ''
+
+ welcome to the simatime network!
+ your host is '${config.networking.hostName}'
+
+ '';
+ users.mutableUsers = false;
+ users.users = { #
+ # bots
+ #
+ deploy = {
+ isNormalUser = true;
+ home = "/home/deploy";
+ openssh.authorizedKeys.keyFiles = [ ./Keys/Deploy.pub ];
+ extraGroups = [ "wheel" ];
+ };
+ #
+ # humans
+ #
+ root.openssh.authorizedKeys.keyFiles = [ ./Keys/Ben.pub ];
+ root.password = "erewhon";
+
+ ben = {
+ description = "Ben Sima";
+ isNormalUser = true;
+ home = "/home/ben";
+ openssh.authorizedKeys.keyFiles = [ ./Keys/Ben.pub ];
+ extraGroups = [ "wheel" "docker" ];
+ hashedPassword =
+ "$6$SGhdoRB6DhWe$elW8RQE1ebe8JKf1ALW8jGZTPCyn2rpq/0J8MV/A9y8qFMEhA.Z2eiexMgptohZAK5kcGOc6HIUgNzJqnDUvY.";
+ };
+ nick = {
+ description = "Nick Sima";
+ isNormalUser = true;
+ home = "/home/nick";
+ openssh.authorizedKeys.keyFiles = [ ./Keys/Nick.pub ];
+ extraGroups = [ "docker" ];
+ };
+ };
+}