summaryrefslogtreecommitdiff
path: root/Biz/Users.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-12-30 12:24:47 -0500
committerBen Sima <ben@bsima.me>2020-12-30 12:50:09 -0500
commit9da4feb106126940264dd27925ea3c19b04aac20 (patch)
tree23a8fe41eb6ef7ef51280e598bebfbf54f851ebc /Biz/Users.nix
parentf0895bfd73c53d9d5d9811c632d8e6f5e99dc0d4 (diff)
bild: build everyting
Now bild knows how to determine between modules that require ghcjs and ghc. It also knows what *not* to build, meaning it won't try to build non-buildable nix targets, for example (unfortunately this is just hardcoded for now), but it also won't build scm or py targets that I haven't implemented yet. It just silently fails, which is fine, because it means I can do `bild **/*` and everything just works. Of course, if I want to build scm code then I will have to implement that, but that's not a priority right now.
Diffstat (limited to 'Biz/Users.nix')
-rw-r--r--Biz/Users.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/Biz/Users.nix b/Biz/Users.nix
index 8a804ca..0f68b50 100644
--- a/Biz/Users.nix
+++ b/Biz/Users.nix
@@ -14,20 +14,20 @@
deploy = {
isNormalUser = true;
home = "/home/deploy";
- openssh.authorizedKeys.keyFiles = [ ./Keys/Deploy.pub ];
+ openssh.authorizedKeys.keyFiles = [ ./Keys/Deploy.key ];
extraGroups = [ "wheel" ];
};
#
# humans
#
- root.openssh.authorizedKeys.keyFiles = [ ./Keys/Ben.pub ];
+ root.openssh.authorizedKeys.keyFiles = [ ./Keys/Ben.key ];
root.password = "erewhon";
ben = {
description = "Ben Sima";
isNormalUser = true;
home = "/home/ben";
- openssh.authorizedKeys.keyFiles = [ ./Keys/Ben.pub ];
+ openssh.authorizedKeys.keyFiles = [ ./Keys/Ben.key ];
extraGroups = [ "wheel" "docker" ];
hashedPassword =
"$6$SGhdoRB6DhWe$elW8RQE1ebe8JKf1ALW8jGZTPCyn2rpq/0J8MV/A9y8qFMEhA.Z2eiexMgptohZAK5kcGOc6HIUgNzJqnDUvY.";
@@ -36,7 +36,7 @@
description = "Nick Sima";
isNormalUser = true;
home = "/home/nick";
- openssh.authorizedKeys.keyFiles = [ ./Keys/Nick.pub ];
+ openssh.authorizedKeys.keyFiles = [ ./Keys/Nick.key ];
extraGroups = [ "docker" ];
};
};