summaryrefslogtreecommitdiff
path: root/Biz/users.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-11-12 17:13:39 -0800
committerBen Sima <ben@bsima.me>2020-11-12 17:21:13 -0800
commit890e44ebcc11c48f7347aa60748a84c48261aa5e (patch)
tree894e30ce7a0c81ef3968c04f82d068a65c15b0f5 /Biz/users.nix
parent19f5402bec9f6346463b83536cc22d7f4525bc18 (diff)
Get Biz.Dev setup again
Also correctly renamed the files (didn't work the first time thanks to the macOS filesystem) and moved the default build.os settings to a OsBase.nix file to be used via imports.
Diffstat (limited to 'Biz/users.nix')
-rw-r--r--Biz/users.nix39
1 files changed, 0 insertions, 39 deletions
diff --git a/Biz/users.nix b/Biz/users.nix
deleted file mode 100644
index c7c4041..0000000
--- a/Biz/users.nix
+++ /dev/null
@@ -1,39 +0,0 @@
-{ config, ... }:
-
-{
- users.motd = ''
-
- welcome to the simatime network!
- your host is '${config.networking.hostName}'
-
- '';
- users.mutableUsers = false;
- users.users = { #
- # bots
- #
- deploy = {
- isNormalUser = true;
- home = "/home/deploy";
- openssh.authorizedKeys.keyFiles = [ ./Keys/Deploy.pub ];
- extraGroups = [ "wheel" ];
- };
- #
- # humans
- #
- root.openssh.authorizedKeys.keyFiles = [ ./Keys/Ben.pub ];
- ben = {
- description = "Ben Sima";
- isNormalUser = true;
- home = "/home/ben";
- openssh.authorizedKeys.keyFiles = [ ./Keys/Ben.pub ];
- extraGroups = [ "wheel" "networkmanager" "docker" ];
- };
- nick = {
- description = "Nick Sima";
- isNormalUser = true;
- home = "/home/nick";
- openssh.authorizedKeys.keyFiles = [ ./Keys/Nick.pub ];
- extraGroups = [ "docker" ];
- };
- };
-}