summaryrefslogtreecommitdiff
path: root/Biz/users.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Biz/users.nix')
-rw-r--r--Biz/users.nix39
1 files changed, 0 insertions, 39 deletions
diff --git a/Biz/users.nix b/Biz/users.nix
deleted file mode 100644
index c7c4041..0000000
--- a/Biz/users.nix
+++ /dev/null
@@ -1,39 +0,0 @@
-{ config, ... }:
-
-{
- users.motd = ''
-
- welcome to the simatime network!
- your host is '${config.networking.hostName}'
-
- '';
- users.mutableUsers = false;
- users.users = { #
- # bots
- #
- deploy = {
- isNormalUser = true;
- home = "/home/deploy";
- openssh.authorizedKeys.keyFiles = [ ./Keys/Deploy.pub ];
- extraGroups = [ "wheel" ];
- };
- #
- # humans
- #
- root.openssh.authorizedKeys.keyFiles = [ ./Keys/Ben.pub ];
- ben = {
- description = "Ben Sima";
- isNormalUser = true;
- home = "/home/ben";
- openssh.authorizedKeys.keyFiles = [ ./Keys/Ben.pub ];
- extraGroups = [ "wheel" "networkmanager" "docker" ];
- };
- nick = {
- description = "Nick Sima";
- isNormalUser = true;
- home = "/home/nick";
- openssh.authorizedKeys.keyFiles = [ ./Keys/Nick.pub ];
- extraGroups = [ "docker" ];
- };
- };
-}