diff options
author | Ben Sima <ben@bsima.me> | 2020-04-19 17:51:48 -0700 |
---|---|---|
committer | Ben Sima <ben@bsima.me> | 2020-04-19 17:51:48 -0700 |
commit | 17247f927d3cec408f6fc541629a5fef5344b07e (patch) | |
tree | 158948bc2473965ea6325040ee57649c1ba0416e /shell.nix | |
parent | 35f0ade5ea77d17544d253f970ef94dd1c7cd9f0 (diff) |
Unify dev packages and base packages
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 19 |
1 files changed, 10 insertions, 9 deletions
@@ -4,17 +4,18 @@ let nixpkgs = import ./nix/nixpkgs.nix; + basepkgs = import ./Biz/packages.nix { inherit (nixpkgs) pkgs; }; + devpkgs = with nixpkgs; [ + hlint + niv + ormolu + python37Packages.black + python37Packages.pylint + wemux + ] in nixpkgs.mkShell ({ name = "bizdev"; - buildInputs = [ - nixpkgs.git - nixpkgs.hlint - nixpkgs.niv - nixpkgs.ormolu - nixpkgs.python37Packages.black - nixpkgs.python37Packages.pylint - nixpkgs.wemux - ]; + buildInputs = devpkgs ++ basepkgs.environment.systemPackages; shellHook = '' echo "biz" | ${nixpkgs.figlet}/bin/figlet | ${nixpkgs.lolcat}/bin/lolcat ''; |