diff options
author | Ben Sima <ben@bsima.me> | 2020-07-10 22:37:25 -0700 |
---|---|---|
committer | Ben Sima <ben@bsima.me> | 2020-07-10 22:37:50 -0700 |
commit | f05bcdc8677efef097b4849e8893d2702640ed2c (patch) | |
tree | fe80f6403b5df4e39b0ac447fc733063579f67d8 /shell.nix | |
parent | 56990a680ab94110c27695bc737ae51b954b993c (diff) |
dev: fixes for macos build
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 12 |
1 files changed, 6 insertions, 6 deletions
@@ -3,20 +3,20 @@ }: let - nixpkgs = import ./nix/nixpkgs.nix; + nixpkgs = import ./nix/default.nix; basepkgs = import ./Biz/packages.nix { inherit (nixpkgs) pkgs; }; devpkgs = with nixpkgs; [ hlint - niv + #niv ormolu python37Packages.black python37Packages.pylint wemux - ] -in nixpkgs.mkShell ({ + ]; +in nixpkgs.mkShell { name = "bizdev"; - buildInputs = devpkgs ++ basepkgs.environment.systemPackages; + buildInputs = devpkgs; shellHook = '' echo "biz" | ${nixpkgs.figlet}/bin/figlet | ${nixpkgs.lolcat}/bin/lolcat ''; -}) +} |