summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2020-07-10 22:37:25 -0700
committerBen Sima <ben@bsima.me>2020-07-10 22:37:50 -0700
commitf05bcdc8677efef097b4849e8893d2702640ed2c (patch)
treefe80f6403b5df4e39b0ac447fc733063579f67d8 /shell.nix
parent56990a680ab94110c27695bc737ae51b954b993c (diff)
dev: fixes for macos build
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/shell.nix b/shell.nix
index b141289..a83b9af 100644
--- a/shell.nix
+++ b/shell.nix
@@ -3,20 +3,20 @@
}:
let
- nixpkgs = import ./nix/nixpkgs.nix;
+ nixpkgs = import ./nix/default.nix;
basepkgs = import ./Biz/packages.nix { inherit (nixpkgs) pkgs; };
devpkgs = with nixpkgs; [
hlint
- niv
+ #niv
ormolu
python37Packages.black
python37Packages.pylint
wemux
- ]
-in nixpkgs.mkShell ({
+ ];
+in nixpkgs.mkShell {
name = "bizdev";
- buildInputs = devpkgs ++ basepkgs.environment.systemPackages;
+ buildInputs = devpkgs;
shellHook = ''
echo "biz" | ${nixpkgs.figlet}/bin/figlet | ${nixpkgs.lolcat}/bin/lolcat
'';
-})
+}