summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/shell.nix b/shell.nix
index b141289..a83b9af 100644
--- a/shell.nix
+++ b/shell.nix
@@ -3,20 +3,20 @@
}:
let
- nixpkgs = import ./nix/nixpkgs.nix;
+ nixpkgs = import ./nix/default.nix;
basepkgs = import ./Biz/packages.nix { inherit (nixpkgs) pkgs; };
devpkgs = with nixpkgs; [
hlint
- niv
+ #niv
ormolu
python37Packages.black
python37Packages.pylint
wemux
- ]
-in nixpkgs.mkShell ({
+ ];
+in nixpkgs.mkShell {
name = "bizdev";
- buildInputs = devpkgs ++ basepkgs.environment.systemPackages;
+ buildInputs = devpkgs;
shellHook = ''
echo "biz" | ${nixpkgs.figlet}/bin/figlet | ${nixpkgs.lolcat}/bin/lolcat
'';
-})
+}